Victoria County CAP Sites Association presents:

The Easy Step Guide to Web Design

Using Google Sites

Building Stronger Communities Through Technology
Course Contents

• Overview
• Lesson 1: Website Setup
• Lesson 2: Design and Organization
• Lesson 3: Adding and Modifying Content
• Appendix

Each lesson includes a list of suggested practice tasks.
Overview

Designing your first website can be daunting and confusing, but Google has made it easy by providing us with Google Sites (sites.google.com).

This manual teaches you step by step, how to set up your website using Google Sites, design and organize your site layout and menu structure, create web pages, add a variety of content to your pages, and modify existing content.

Google Sites is simple and very user friendly. If you can navigate a web browser, you can design websites with Google Sites. Let's show you how.
Who should use Google Sites?

• Google Sites is very user friendly, and simple to understand. It is suitable for beginners.

• The simple Google Sites interface limits its capability for free HTML coding. Google Sites is restrictive in some ways, and is thus not the best tool for experts, although still very useful, particularly for company intranets and group sites.

• Anyone interested in Web Design will likely find Google Sites a very convenient application.
Course Goals

1. Successfully set up a website on Google Sites
2. Understand very basic website design concepts
3. Know different types of web page content
4. Understand web page editing tools
Lesson 1

Website Setup
Requirements

- Computer with internet access
- Web browser
- Google account: [https://www.google.com/accounts/NewAccount](https://www.google.com/accounts/NewAccount)
- Log in at [sites.google.com](https://sites.google.com) with your Google Account.
- Requirements change slightly when using Google Apps: see Appendix
Create a new site

1. Log in to Google Sites at sites.google.com.

2. Click on "Create new site".

3. Enter site name.

4. Enter site URL. *Note: you cannot change this URL later!*

5. Optionally, enter site category and description.

6. Pick your site theme (layout).

7. Click on "Create site".
Site name: Guide to Web Design

Your site will be located at this URL:
http://sites.google.com/a/vccaps.com/guide-to-web-design
Site URLs can only use the following characters: -, A-Z, a-z, 0-9

Site categories (optional) enter one or more categories separated by commas, e.g. "marketing, finance"

- easy step guides

Site description (optional) enter a short description of this site

This site complements the "Easy Step Guide to Web Design using Google Sites"

Collaborate with
- Everybody at vccaps.com
- Only people I specify can view this site
- Also let anyone in the world view this site (make it public)

Site theme
- Default
- Charcoal
- Garden

More themes...
You just created a website

Your first empty website is now created. Congratulations!

Note the 4 buttons on top of your website: Create new page, Edit page, More actions, Site settings. You can only see these if you are logged in.

Guide to Web Design
The Google Sites Menu

• **Create new page**
  - You can create 5 different types of pages.
  - Covered in Lesson 2.

• **Edit page**
  - This is where you add and modify the content of pages.
  - Covered in Lesson 3.
The Google Sites Menu (continued)

- More actions
  - 8 specific actions that are important for the organization and accessibility of your site.
    - Covered in Lesson 2.

- Site settings
  - 3 areas that modify site-wide settings
    - Covered in Lesson 1.
Site Settings: Sharing

• You can share a site with specific users or with the world.

• For a public website checkmark "Anyone in the world may view this site".

• You can also invite specific people by email address as owners, collaborators, or viewers.
Site Settings: Sharing

Owners can:
- Invite other owners, collaborators, or viewers
- Change site name, themes, and layout
- Delete the site
- Do everything a collaborator can do

Collaborators can:
- Create, edit, delete, and move pages
- Add attachments and comments
- Add/remove pages to the sidebar navigation
- Subscribe to site and page changes

Viewers can:
- Only view pages
Site Settings: Other Stuff

In "Other Stuff" you can modify these settings:

- site name, category, and description
- landing page (which is usually the home page)
- enable/disable statistics (if you use Google Analytics)
- enable/disable metatag verification (if you use Google Webmaster Tools)
- language for site emails

You can also delete the site here. Think twice before you press the delete button.
Site name
Guide to Web Design

Show site name at top of pages

Site Category
easy step guides

Enter one or more comma-separated tags that others can use to find this workspace (e.g. Business, Personal)

Site Description
This site complements the "Easy Step Guide to Web Design using Google Sites"

Enter a short description that summarizes the purpose of this site.

Landing Page
[Home] Change
This is the default landing page that users will see when they visit your site: (http://sites.google.com/a/vccaps.com/guide-to-web-design/).

Statistics

Enable Google Analytics for this site Learn more
Paste your Analytics Web Property ID here:

Example: UA-12345-12

Web Address Mapping
Your Domain administrators can now map this Site to a web address like http://guide-to-web-design.vccaps.com.

Google Webmaster Tools verification
Enter your Google Webmaster Tools meta tag verification below. Learn more
Site Settings: Appearance

The Appearance area is divided into 3 tabs:

1. Site Elements
2. Colors and Fonts
3. Themes

Note:
After making changes here you must click on "Save changes".
Site Settings: Site Elements

In Site Elements you can change:

• Site layout
• Site logo
• Sidebar items

Sidebar items:
1. Navigation menu
2. Simple text
3. Recent site activity
4. My recent site activity
5. Countdown to a certain point in time
If you click on "Change site layout" you can make the following changes:

- Site width
- Header yes/no
- Header height
- Sidebar yes/no
- Sidebar left/right
- Sidebar width
Site Settings: Site Elements > Site Logo

You have 3 choices for the website logo:

- Domain default (which is set up in Google Apps)
- Upload a custom logo from your computer
- No logo
Site Settings: Colors and Fonts

Here you have control over:

- Fonts
- Colors
- Background images

[Image of a website appearance settings interface]

Choose a color:
Or edit color hex code:
#000000
Example: #efefef
A theme is a color template for your website.

There are 23 themes to choose from.

- Click on the "Preview" button below a theme to see how your site would look like in that theme.
- If you have decided on a theme, make sure that it is selected, and click on "Save changes".
Themes are combinations of site layouts, colors and images that we have pre-packaged for you. Changing your theme will discard any changes you made in Colors and Fonts. Your Site Elements will be retained.
Suggestions for practice

1. Sign in at sites.google.com with your Google Apps or your Google account, and create your first empty site.
2. Change the sharing settings, so that everybody in the world can view your site.
3. Change the site logo to a logo of your choice.
4. Change the page font color to hot pink.
5. Change the site theme to "Wintermint".
6. Delete the "Recent Site Activity" sidebar item.
7. Add a new "Countdown" sidebar item, so that it counts down to your upcoming birthday.
In Google Sites, you can create 5 different types of pages:

- Web Page
- Dashboard
- Announcements
- File Cabinet
- List
What is a Web Page?

A web page is an unstructured page where you can enter text, images, tables, and embed spreadsheets, presentations, videos, and more.

The Web Page has standard formatting controls like bold, italic, underline, font control, text color, and text highlighting. You can create bulleted lists, numbered lists, and easily link to other pages in your site.

You can attach documents from your hard drive to the bottom of the page, and allow other site collaborators to comment on your pages.
This is a web page. A web page does not have a pre-programmed special format like the other 4 page types. You can do pretty much anything on a web page.

Here, you can use tables to organize your page:

<table>
<thead>
<tr>
<th>This is a cell.</th>
<th>This is a cell in column 2, row 1</th>
<th>Below is a horizontal line. It only spreads the width of the table cell.</th>
</tr>
</thead>
<tbody>
<tr>
<td>This is a nested Table.</td>
<td>This is basically a table within a table.</td>
<td>Above is an image.</td>
</tr>
<tr>
<td>More precisely, this is a table within a cell of the parent table.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>This is the second row of this table.</td>
<td>row 2, column 2, right-aligned.</td>
<td>Believe it or not, but this is row 2, column 3</td>
</tr>
</tbody>
</table>

This is what the html code for a horizontal line says:

```html
<hr size="2" width="100%">
```

Below is a different horizontal line, with the entire section centered:

```html
/hr size="2" width="80%">
```

This link goes to Dashboard.
What is a Dashboard?

A Dashboard page is a two column webpage with four placeholder gadgets to make it easy to get started creating an overview of information.

Gadgets are boxes of web content that can contain:

- News
- Weather Forecasts
- Maps
- Games
- Text Boxes
  and much more.
What is an Announcements Page?

An Announcement page is a page which makes it easy for an individual or group to post chronological information like news, status updates, or notable events.

It can be used to post organizational news, post project updates, announce new releases, post interesting links from around the web, as a simple blog, and more.
Announcements

Halloween has been moved to April 1st
Nov 26, 2008 1:57 PM posted by Michael Riegner

According to What's My Name International, Halloween has been moved to April Fools Day. This is not funny. It scares me. Let's move it back to October 31. Comments are invited.

(Post Title goes here)
Nov 26, 2008 1:48 PM posted by Michael Riegner [updated Nov 26, 2008 1:56 PM]

This is the post body.
The Announcement Page lists all the posts.

The announcement page is structured like this:

<table>
<thead>
<tr>
<th>Announcement Page</th>
<th>Post 1</th>
<th>Comment 1</th>
<th>Comment 2</th>
<th>Comment 3</th>
<th>Comment 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Post 2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Post 3</td>
<td></td>
<td>Comment 1</td>
<td>Comment 2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Post 4</td>
<td></td>
<td>Attachment 1</td>
<td>Attachment 2</td>
<td>Comment 1</td>
<td>Comment 2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Comment 2</td>
<td>Comment 3</td>
</tr>
</tbody>
</table>

When you click on a post, you actually get to a subpage that contains only the one post, its attachments and comments.

This post here has a file attachment, and no comments (at the time of writing).
What is a File Cabinet?

A File Cabinet allows you to manage documents from your hard drive and organize them into folders.

This can be used to organize common documents in one place.

Version history is stored for documents so you can always return to an earlier version.
You can use a file cabinet page as a storage place for documents.

### documents (Remove)

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
<th>Size</th>
<th>Version</th>
<th>Last Updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAP_English_brochure.pdf</td>
<td>NS CAP brochure</td>
<td>577k</td>
<td>v. 2</td>
<td>3 hours ago</td>
</tr>
<tr>
<td>cap_sites_street_addresses.xls</td>
<td>NS CAP site addresses</td>
<td>45k</td>
<td>v. 3</td>
<td>3 hours ago</td>
</tr>
<tr>
<td>CuteFTP.doc</td>
<td>Cute FTP Tutorial</td>
<td></td>
<td></td>
<td>3 hours ago</td>
</tr>
</tbody>
</table>

### images (Remove)

<table>
<thead>
<tr>
<th>File Name</th>
<th>Description</th>
<th>Size</th>
<th>Version</th>
<th>Last Updated</th>
</tr>
</thead>
<tbody>
<tr>
<td>logo.png</td>
<td>vccaps website logo</td>
<td>97k</td>
<td>v. 3</td>
<td>4 hours ago</td>
</tr>
<tr>
<td>vccapslogo300dpi.JPEG</td>
<td>vccaps logo 300 dpi</td>
<td>175k</td>
<td>v. 2</td>
<td>4 hours ago</td>
</tr>
<tr>
<td>vccapslogo300dpi-no-text.JPG</td>
<td>vccaps logo w/o text 300dpi</td>
<td>19k</td>
<td>v. 2</td>
<td>4 hours ago</td>
</tr>
<tr>
<td>vccapslogo300dpi-no-text_watermark.JPG</td>
<td>vccaps logo w/o text 300dpi watermark</td>
<td>8k</td>
<td>v. 2</td>
<td>4 hours ago</td>
</tr>
<tr>
<td>vccaps_logo.jpg</td>
<td>vccaps logo beige background</td>
<td>8k</td>
<td>v. 3</td>
<td>4 hours ago</td>
</tr>
</tbody>
</table>
What is a List?

List pages allow you to easily track lists of information.

You can choose from a list of templates or configure your own custom columns.

Items can be easily added, updated, and removed.
This is a list of coordinates for a trail that you can find by using GPS.

<table>
<thead>
<tr>
<th>Point Name</th>
<th>Degrees NORTH</th>
<th>Degrees WEST</th>
<th>Point Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>005</td>
<td>46deg 09.549'</td>
<td>60deg 46.898'</td>
<td>Turn left here</td>
</tr>
<tr>
<td>007</td>
<td>46deg 09.698'</td>
<td>60deg 46.847'</td>
<td>turn right here</td>
</tr>
<tr>
<td>008</td>
<td>46deg 09.817'</td>
<td>60deg 46.714'</td>
<td>sway left slightly</td>
</tr>
<tr>
<td>009</td>
<td>46deg 09.863'</td>
<td>60deg 46.718'</td>
<td>turn right sharply (River Option Point)</td>
</tr>
<tr>
<td>011</td>
<td>46deg 09.809'</td>
<td>60deg 46.692'</td>
<td>sway right slightly</td>
</tr>
<tr>
<td>012</td>
<td>46deg 09.750'</td>
<td>60deg 46.758'</td>
<td>Baddeck River - turn around here</td>
</tr>
<tr>
<td>006</td>
<td>46deg 09.687'</td>
<td>60deg 46.819'</td>
<td>Vista of Baddeck River</td>
</tr>
<tr>
<td>013</td>
<td>46deg 09.853'</td>
<td>60deg 46.675'</td>
<td>turn left here</td>
</tr>
<tr>
<td>014</td>
<td>46deg 09.868'</td>
<td>60deg 46.718'</td>
<td>sway right slightly</td>
</tr>
<tr>
<td>015</td>
<td>46deg 09.947'</td>
<td>60deg 46.764'</td>
<td>sway left slightly</td>
</tr>
<tr>
<td>016</td>
<td>46deg 09.955'</td>
<td>60deg 46.819'</td>
<td>turn left sharply</td>
</tr>
<tr>
<td>017</td>
<td>46deg 09.917'</td>
<td>60deg 46.775'</td>
<td>turn right</td>
</tr>
<tr>
<td>018</td>
<td>46deg 09.898'</td>
<td>60deg 46.804'</td>
<td>turn right</td>
</tr>
<tr>
<td>019</td>
<td>46deg 09.906'</td>
<td>60deg 46.846'</td>
<td>Road</td>
</tr>
<tr>
<td>020</td>
<td>46deg 09.913'</td>
<td>60deg 46.872'</td>
<td>Tree near the Cash</td>
</tr>
<tr>
<td>CASH</td>
<td>46deg 09.920'</td>
<td>60deg 46.873'</td>
<td>The Geo Cash</td>
</tr>
<tr>
<td>021</td>
<td>46deg 09.905'</td>
<td>60deg 46.829'</td>
<td>turn right here</td>
</tr>
</tbody>
</table>
Before you start building your site, plan out its rough content with pen and paper.

For each page on your site, write down the following:

- Page Name
- Page Type
- Page Location
Page Hierarchy

Page location refers to its place within the page hierarchy. Draw a diagram for your site that looks something like this:

- Home (announcement page)
- Main Page 1 (web page)
  - Sub Page 1 (list)
  - Sub Page 2 (list)
  - Sub Page 3 (file cabinet)
- Main Page 2 (web page)
  - Sub Page 1 (web page)
  - Sub Page 2 (web page)
  - Sub Page 1 (web page)
- Main Page 3 (web page)
Website: Outdoor Activities in the Maritimes

Top Level Pages

Home Page (Announcement page)
- Nova Scotia (Web page)
  - Hiking (Web Page)
  - Biking (Web Page)
  - Canoeing (Web Page)
  - Camping (Web Page)
  - Swimming (Web Page)

- New Brunswick (Web page)
  - Hiking (Web Page)
  - Biking (Web Page)
  - Canoeing (Web Page)
  - Camping (Web Page)
  - Swimming (Web Page)

- Prince Edward Island (Web page)
  - Hiking (Web Page)
  - Biking (Web Page)
  - Canoeing (Web Page)
  - Camping (Web Page)
  - Swimming (Web Page)

- Contact (List page)
- Privacy (Web page)
- Sitemap (Automatically created)

Sub Pages

- Pollets Cove Trail (Web Page)
- Skyline Trail (Web Page)
- Mabou Highlands Trails (Web Page)
- Usages Ban Falls Trail (Web Page)
- North River Falls Trail (Web Page)
- Egypt Falls Trail (Web Page)
- Cape Split Trail (Web Page)

Sub Pages Level 2

Etc.
The page hierarchy is a sitemap of your website.

The home page and all main pages (aka top level pages) are those pages that are suitable to appear in the navigation menu.

A sub page belongs to a particular parent page, which can be a main page, or a sub page. You can put a sub page "under" a parent page.
Create Pages

Now that you have your website planned, follow these steps:

1. Click on "Create new page".

2. Enter Page Name.

3. Choose Page Type.

4. Choose Page Location within Hierarchy.

5. Click on "Create Page".

6. Repeat steps 1-5 for each page.
Create the Menu

All of your pages are now created. You may notice that none of your pages show up in the navigation menu, which still only contains "Home" and "Sitemap". To create the menu:

1. Click on "Sitemap".
2. Click on a top level page which you want to see in the navigation menu.
3. Click on "More Actions".
4. Click on "Page Settings".
5. Checkmark "Show this in Navigation".
6. Click on "Save".
7. Repeat steps 1-6 for each page.
We are now ready to explore the remainder of the "More Actions" button.

Note that the top six options are page-specific, i.e., they affect only the one page that is displayed at the time the button is clicked.
More Actions Menu (continued)

- **Subscribe to page changes:**
  Click this once, and you will be notified by email of any changes made to the current page. To undo this, click the same button once again, which has now changed to "Unsubscribe from page changes".

- **Subscribe to site changes:**
  This button acts in the same manner as the above, except that it applies to all pages in your site.

- **Preview page as viewer:**
  Click this to see the current page in "viewer preview" mode. A viewer is somebody who is not logged in.
More Actions Menu (continued)

• **Print:**
  This opens a new browser window where the current page is displayed in "printer-friendly" mode. You can then print this page by clicking "Print" in your web browser.

• **Delete:**
  This permanently deletes the current page. Click on "Delete" when you are being asked "Really delete page?". Or press cancel if you want to think this over.
To move a page (change its location within the hierarchy):

1. Click "Move" to open a window that displays the page hierarchy of all pages in your site except the current page.

2. Click the one page you want to move the current page under (i.e., click on the new parent page).

3. If you want to move the current page to the top level, click on the topmost "page", which displays the title of your website.

4. Click on "Move".
More Actions Menu: Page Settings

In Page settings you can **toggle the visibility** of these items:

- Link in the navigation menu
- Page title on page top
- Automatic links to sub pages at page bottom
- File attachments
- User comments

You can also change the page URL here.
Page Settings

- Show this in "Navigation" in the sidebar

- Show page title
- Show links to sub-pages
- Allow attachments
- Allow comments

Page URL:

Home

Page URLs can only use the following characters: - , A-Z, a-z, 0-9

Save  Cancel
The sitemap shows you the page hierarchy with all pages that your website contains, sorted alphabetically. Here, you can click on:

- a particular page to visit that page.
- "Expand all" to also see all sub pages (default view).
- "Collapse all" to see only top level pages.
- "List View" to access an alphabetical list of pages that does not distinguish between sub and main pages. Included here is also who each page was created or last updated by, with time stamp.
Suggestions for Practice

1. Plan your own website on paper.
2. Create all pages for your website at "top level".
3. Move pages you want as sub pages under the parent page.
4. Create the navigation menu.
5. Visit the Site Settings to edit the order in which links appear in the navigation menu.
6. Disallow comments and attachments on pages of your choice.
7. Create a Dashboard named "Test Page".
8. Play around with your Test Page (add gadgets).
10. Delete your Test Page.
Lesson 3

Adding and Modifying Content
Lesson 3 exclusively focuses on the one button we have not covered yet in this manual: the "Edit Page" button.

The 5 different page types have different editing options, and we will deal with each in order:

1. Web Page
2. Dashboard
3. Announcements
4. File Cabinet
5. List
Web Page: Toolbar

If your page is of the Web Page type, clicking "Edit Page" displays this toolbar:

Whenever you have made changes to any page, you must click "Save". Otherwise, your changes will not take effect.

Clicking "Cancel" will also undo any unsaved changes to the page.

Clicking either "Save" or "Cancel" also exits the editing mode.
Web Page: Writing Text

If your main objective is to provide written information on your web page, simply type your text in the large box below the page title, and that is all you need to do.

This box contains the Page Title

Start writing in this box here... and format your text using the above toolbar.
You can insert a variety of elements into your page:

- Basic page elements (e.g. images, links)
- Google Calendar
- Google Docs files
- Videos (Google or YouTube)
- Gadgets

Pay attention to the position of your cursor: anything you insert is inserted at this location.
• Clear Formatting and Align are duplicates from the text editing toolbar.

• Various headings, strikethrough, superscript and subscript are only accessible here.
You can use tables to organize content in rows and columns.

The intersection of row and column is called a cell.

When inserting a table, you can decide how many rows and columns you want.

When you click into a cell, you can insert more rows and columns that appear above, below, left, or right of the cell containing the cursor.

You can also delete rows, columns, or tables.
You can change the default One-column page layout to Two-column.

Two-column layout splits your page into 2 fixed columns of the same width.

Two-column layout is suitable for newspaper-like text articles, including smaller images.

If you want to add larger images, videos, or gadgets, the One-column layout is recommended.
• Visit this website, which is complementing this manual:
  http://sites.google.com/a/vccaps.com/guide-to-web-design/

• Click Easy Step Pages.

• Each of these pages guides you step by step to exactly duplicate those pages yourself.
  
  o [Basic Text Editing (web page)](http://sites.google.com/a/vccaps.com/guide-to-web-design/basic-text-editing)
  o [Advanced Editing (web page)](http://sites.google.com/a/vccaps.com/guide-to-web-design/advanced-editing)
  o [Table Editing (web page)](http://sites.google.com/a/vccaps.com/guide-to-web-design/table-editing)
Easy Step Page: Basic Text Editing

This page is an example web page that you can duplicate by following these simple steps. Learn by doing, and create your own web page that looks just like this one.

1. Click bullet list. Click bullet list again. Click increase indent 4 times.
2. Click Layout > Two Column (and then click again in the left column to put the cursor here).
3. Select this text. Change font type to Courier New.
4. Select this text. Change font size to 16.
5. Select this text. Click Bold.
6. Select this text. Click Italic.
7. Select this text. Click underline.
8. Select this text. Change font color to red.
9. Select this text. Change font background color to orange.
10. Select this text. Click Link. Click Web Address. Enter www.vccaps.com. Click OK.
11. Click on the empty white space in the right column.

Click Align left. Click decrease indent 3 times.
Select this text. Change font size to 16 and click italic.
Select the entire line of text above and copy it below.
Select this text. Click Remove formatting. Click undo.
Select this text. Change font size to 24. Click HTML. Scroll down to the bottom where it says "<font size=6>this text</font>". Replace the 6 with a 1. Click Update.

Click Save.
Easy Step Page: Advanced Editing

This page is an example web page that you can duplicate by following these simple steps. Learn by doing, and create your own web page that looks just like this one.

1. Click Numbered List.
2. Click on the line above to put the cursor there.
3. Click Insert > Image. Click Browse > Add image.
4. Click on the image that appears, and more options will show up.
5. Click Wrap On. Click Align Right. Click Size Medium.

6. "This is a Heading."
7. Click on the line above to put the cursor there.
8. Click Format > Heading.

9. "This is a Sub-heading."
10. Click on the line above to put the cursor there.
11. Click Format > Sub-heading.

12. "This is a Minor heading."
13. Click on the line above to put the cursor there.
15. Click Insert > Table of Contents

Contents

1 "This is a Heading."
1.1 "This is a Sub-heading."
1.1.1 "This is a Minor heading."
Easy Step Page: Table Editing

Click Table > Insert Table > 3x2.

1. Click on this table cell.
2. Widen it by dragging the middle right square button further to the right.
3. Do the same to the other two columns.
4. Notice how changing the cell width changes the width of the entire column.
5. Widen this column all the way to the very right of the page.
6. Click Table > Insert row down 3 times.
7. Notice how there are now 5 rows in this table.
8. Click in the cell below. Click Table > Insert Table > 2x2.

18. Type the following:
\[ x^2 = x_2 = \text{WRONG} \]
19. Select the first "2". Click Format > Superscript.
20. Select the second "2". Click Format > Subscript.
21. Select "WRONG". Click Format > Strikethrough.
22. Click in the empty line between 23 and 24. Click Insert > Horizontal Line.
23. Understand that Horizontal Lines are very useful when trying to separate content from other content. Horizontal Lines by default span 100% of the width at their location. In a table, that means 100% of cell/column width. Outside a table that means 100% of page width.
24. Click in the empty line between 23 and 24. Click Insert > Horizontal Line.
25. Click on the empty row below. Click Table > Delete row.
26. Repeat step 25 to delete the other two empty rows below.
27. Select this text. Click Link. Click on your existing page Home. Click OK. Understand that this is a link to a page within your site.
28. Select this text. Click Link. Click Web Address. Type www.vccaps.com. Understand that this is a link to another website.
29. Click into this table cell, and widen it.
30. Widen the second column all the way to the right.
31. Understand that this is a table within a table, or more precisely: a table within a cell of another table. This is also called a Nested Table.
32. Click in the cell below. Click Table > Insert Table > 2x2.
33. Click into this table cell, and widen it.
34. Widen the second column all the way to the right.
35. Understand that this is also a nested table. This table is a table within a table.
36. Click in the cell on the right. Click Insert > Image, and follow the wizard.
37. Click on the image. Click Size Small.
Easy Step Pages: Dashboard

• Visit this website, which is complementing this manual:
  http://sites.google.com/a/vccaps.com/guide-to-web-design/

• Click Easy Step Pages.

• Each of these pages guides you step by step to exactly duplicate those pages yourself.
  o Inserting Google Docs (dashboard)
  o Inserting Calendars (dashboard)
  o Inserting Gadgets (dashboard)
Easy Step Page: Inserting Calendars

Google Calendar

NLC Web Design Open Lab Hours

1. Click in the top right gadget.
2. Click Text box.
3. Copy and paste this text.
4. Click Save.
6. Click Settings. Click on a Published (made public) Calendar.
7. Click HTML.
8. Copy the URL.
9. Click OK.
10. Go back to Google Sites.
11. Click in the top left gadget.
12. Click Calendar.
13. Enter 500 as height.
14. Click Save.
15. Note that you can modify the properties of any gadget by clicking on it, and then clicking properties.

Events shown in time zone: Atlantic Time - Halifax
1. Click in the top right gadget. Click Text box.
2. Copy and paste this text. Click Save.
3. Click in the top left gadget. Click Document.
4. Select a document. Note that you must have a Published (made public) document saved in Google Docs. Otherwise there will be nothing to insert.
5. Click Select.
6. Enter 160 as height.
7. Click Save.

1. Click in the bottom right gadget.
2. Click Text box.
3. Copy and paste this text.
4. Click Save.
5. Click in the bottom left gadget.
6. Click Presentation.
7. Select a presentation. Note that you must have a Published (made public) presentation saved in Google Docs. Otherwise there will be nothing to insert.
8. Click Select.
10. Click Save.
Easy Step Page: Inserting Gadgets

1. Click in the top right gadget.
2. Click Text box.
3. Copy and paste this text.
4. Click Save.
5. Click in the top left gadget.
6. Click Video > Google Video.
7. Paste the URL of the Google Video.
8. Click Save.

1. Click in the bottom left gadget.
2. Click Text box.
3. Copy and paste this text.
4. Click Save.
5. Click in the bottom right gadget.
6. Click More...
7. Click on the Gadget of your choice, e.g. News > Clouds.
8. Click OK.
Easy Step Pages (continued)

- Visit this website, which is complementing this manual:

- Click Easy Step Pages.

- Each of these pages guides you step by step to exactly duplicate those pages yourself.

  - Editing Announcements
  - Editing File Cabinets
  - Editing Lists
**Introduction to Posts**

Dec 11, 2008 7:22 PM posted by Michael Riegner

1. Understand that one of the unique things about the announcements page is that you do not have to click Edit in order to add content to the page.
2. Do NOT click Edit for now.
3. Click New Post.
4. Understand that you are now already in editing mode. You are now editing a "Post", which is in fact going to be a subpage of the announcements page.
5. Click in the title that currently says "Untitled Post".
6. Enter the title "Introduction to Posts" for your post.
7. Copy and past this text in order to duplicate the post.
8. Click Save.
9. Click "Easy Step Page: Editing Announcements" above the post title to get back to the announcements page.

---

**Post is Web Page**


1. Understand that a post is really a Web Page that is a subpage of the announcements page.
2. Note that you have the same editing options as you have when editing a web page.
3. If you need to edit a post after having saved it, go to the announcements page, and click Edit Post.

(EDIT POST)
1. Understand that you do not need to click Edit to add files to a file cabinet page. However, you need to click Edit in order to write this text. Know that you can edit this portion of a file cabinet just as you would edit a web page.


3. Repeat step 2 to upload another file.

4. Checkmark the box in front of your first file. Click Move to > New folder. Enter a name for the new folder. Click Save.

5. Repeat step 4 to move the other file into a new folder.

6. Understand that you can use folders to organize your files.

7. Understand that you can checkmark a file, and delete it by clicking Delete.

8. Understand that you can checkmark a file, click Subscribe to changes, and be notified by email of any changes to the file.
1. Understand that you do not need to click Edit to create or modify a list page. However, you need to click Edit in order to write this text. Know that you can edit this portion of a list page just as you would edit a web page.
2. Click Create a custom list.
3. Enter a name for the first column.
4. Click Add new column.
5. Enter a name for the new column. Choose column type, e.g., text.
6. Repeat steps 4 and 5 to add more columns. Click Save.
7. Note that you can modify the columns by clicking Customize this list.
8. Click Add item. Fill out the form. Click Save.
9. Repeat step 8 to populate your list with information.
10. Note that you can sort the list by clicking Sort under a particular column.

### Page Type Summary

<table>
<thead>
<tr>
<th>Page Type</th>
<th>Suitability</th>
<th>Attachments Possible</th>
<th>Comments Possible</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Page</td>
<td>Anything</td>
<td>✓</td>
<td>✓</td>
<td>Web Page</td>
</tr>
<tr>
<td>Dashboard</td>
<td>Gadgets</td>
<td>✓</td>
<td>✓</td>
<td>Dashboard</td>
</tr>
<tr>
<td>Announcements</td>
<td>Message Boards, News</td>
<td>✓</td>
<td>✓</td>
<td>Announcements</td>
</tr>
<tr>
<td>File Cabinet</td>
<td>Uploading &amp; Organizing Files</td>
<td>✓</td>
<td>✓</td>
<td>File Cabinet</td>
</tr>
<tr>
<td>List</td>
<td>Tabular Information (rows/columns)</td>
<td>✓</td>
<td>✓</td>
<td>List</td>
</tr>
</tbody>
</table>
• Visit this website, which is complementing this manual:
  http://sites.google.com/a/vccaps.com/guide-to-web-design/

• Click Easy Step Pages.

• Each of these pages guides you step by step to exactly duplicate those pages yourself.
  - Attaching Files
  - Making Comments
1. Click on the Plus symbol to the left of "Attachments" at the bottom of this page.
2. Click Browse. Select a file and confirm your choice.
3. Note that your file is now attached, and can be accessed by clicking on it.
4. To remove the file, click Remove.
5. To upload an updated version of your file, simply upload the updated file (with the same file name) again.

Attachments (3)

- lesson3-15.jpg 68k - on Dec 12, 2008 2:48 PM by Michael Riegner (version 1) - Remove
- lesson3-16.jpg 71k - on Dec 12, 2008 2:48 PM by Michael Riegner (version 1) - Remove
- lesson3-17.jpg 41k - on Dec 12, 2008 2:50 PM by Michael Riegner (version 2 / earlier versions) - Remove

Attach a file: [File Field]
Easy Step Page: Making Comments

1. Click on the Plus symbol to the left of "Comments" at the bottom of this page.
2. Enter your comment as text.
3. Click Add comment.
4. Understand that your name and the date is recorded, and displayed above the comment.
5. Note that you can click Remove to delete the comment.
6. Repeat steps 2 and 3 to add more comments.

Comments (3)

Michael Riegner - Dec 12, 2008 3:04 PM - Remove
This is the last Easy Step Page. You are now an expert on Google Sites.

Corrina Petersen - Dec 12, 2008 3:09 PM - Remove
I am not sure that I am an expert yet but thanks for your help!

Michael Riegner - Dec 12, 2008 3:09 PM - Remove
You are welcome.
Suggestions for practice

1. Recreate all 11 Easy Step Pages.
2. Add a web page that contains a dozen gadgets.
3. Create your own website, and make it available to the public.
4. Create a personal website, and only share it with your family and friends.
Appendix: Google Apps Requirements

In order to use Google Sites with Google Apps, you need a Google Apps account (www.google.com/a).

Once you are set up with Google Apps, and it is properly configured, you can improve your Google Sites experience.

VCCAPS also publishes Easy Step Guides to Google Apps. They are available here:

www.vccaps.com/easy-step-guides
Appendix: Google Apps Requirements (cont.)

With Google Apps, you will be able to access your Google Sites website through your own domain such as: www.vccaps.com OR capsite.middleriver.ca

Without Google Apps, you can only access your website at a location such as: sites.google.com/site/mywebsite/

Google Sites with Google Apps also gives you Google Gmail for your domain, more storage space, and more options.
The End